<!DOCTYPE html>
<html lang="en-us" id="ngin1862">
<head>
<!--[if lte IE 9]>
    <meta http-equiv="refresh" content="0; url=/unsupported_browser" />
    <script type="text/javascript">
        window.top.location = '/unsupported_browser';
    </script>
<![endif]-->
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"7b8dc0b815","applicationID":"16731","transactionName":"IQkMERZcXApQQRZeBBUVPQQWR1kFWVYWQwkNEQ==","queueTime":0,"applicationTime":24,"agent":""}</script>
<script>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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1" />
  <meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="8rtTwHwh/9xJdlRb1H+2q6UJZ0u+w4ZtvbP3XAPcjbPWZlz+SmNznOIJsBW/UDEqFxS6neWBcDdUrmIgRsxjOg==" />
<meta name="trace-id" content="7477c76f-bf2c-4571-8f89-114a0fae3965" />
  <title>Mayer Lutheran snags its first football state title, winning the Class 1A final</title>

  <!-- Custom | application -->

  <!-- Icons v4 -->
<link rel="shortcut icon" href="https://assets.ngin.com/site_files/1862/favicon.ico" />


  <link href="https://cdn2.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_120.png" rel="apple-touch-icon" />
  <link href="https://cdn1.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_152.png" rel="apple-touch-icon" sizes="152x152" />
  <link href="https://cdn1.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_167.png" rel="apple-touch-icon" sizes="167x167" />
  <link href="https://cdn1.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_180.png" rel="apple-touch-icon" sizes="180x180" />
  <link href="https://cdn3.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_192.png" rel="icon" sizes="192x192" />
  <link href="https://cdn2.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_128.png" rel="icon" sizes="128x128" />



  <link href="https://cdn1.sportngin.com/attachments/favicon_graphic/9697/9005/favicon_size_16.png" rel="icon" type="image/png" sizes="16x16">
  <link href="https://cdn2.sportngin.com/attachments/favicon_graphic/9697/9005/favicon_size_32.png" rel="icon" type="image/png" sizes="32x32">
  <link href="https://cdn2.sportngin.com/attachments/favicon_graphic/9697/9005/favicon_size_96.png" rel="icon" type="image/png" sizes="96x96">



  <meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mnfootballhub" />
<meta name="twitter:creator" content="@mnfootballhub" />
<meta property="og:description" content="The official home of Minnesota high school football." />
<meta name="description" content="Follow the MN Football Hub for complete Star Tribune coverage of high school football and the Minnesota state high school tournament, including scores, schedules, rankings, statistics and more."/>

  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1862/custom/page_elements.css?1634232131" />
  
    <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1862/custom/sports.css?1634232131" />
  
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1862/custom/default.css?1634232131" />
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/jquery_treeTable.css?1634232131" />
  <link rel="stylesheet" media="screen" href="/stylesheets/sn/shared_components.css?1634232131" />
  <link rel="stylesheet" media="screen" href="//s3.amazonaws.com/sportngin-snap-production/ui_themes/ngin/latest/ngin-bar.css?20190108" />

  
  <!--[if IE 9]>
  <script type="text/javascript" charset="utf-8">var IE = "9";</script>
  <link rel="stylesheet" media="screen" href="/stylesheets/ie9/default_ie9.css?1634232131" />
<![endif]-->

<!--[if IE 8]>
  <script type="text/javascript" charset="utf-8">var IE = "8";</script>
<![endif]-->

<!--[if IE 7]>
  <script type="text/javascript" charset="utf-8">var IE = "7";</script>
<![endif]-->

<!--[if IE 6]>
  <script type="text/javascript" charset="utf-8">var IE = "6";</script>
<![endif]-->

<!--[if lte IE 6]>
  <script type="text/javascript" charset="utf-8">var IE = "6";</script>
<![endif]-->

<!--[if !IE]><!--><script type="text/javascript" charset="utf-8">var IE = null;</script><!-- <![endif]-->


  
      
      <script src="/javascripts/semparticle.js?1624378150"></script>
    
    <script>
//<![CDATA[
window.dataLayer.push({ intercom: { renderIntercom: false } })
//]]>
</script>
    <script>
//<![CDATA[
window.SeMParticle.init({ currentEnv: 'production', platProp: 'ngin', platformSubSec: 'cms', orgId: 1838 })
//]]>
</script>

<!-- Needs to be as high in the <head> of the page as possible -->

<!-- Google Tag Manager Data Layer -->
<script>

  window.addEventListener('message', function(event){
    if(event.data === 'utd:ready') {

      var displayAds = (true || true);

      var platformDL = {'siteId': '1862', 'siteName': 'MN Football Hub | High School Football News, Scores &amp; Standings',
                        'siteShortName': 'MN Football Hub', 'sportType': 'football',
                        'addrState': 'MN', 'displayAds': displayAds,
                        'inEditMode': false,
                        'propertySubSection': 'cms', 'property': 'Ngin'};

      var quantcastDL = {'quantcastID': ''};

      var elevioAdditionalGroups = ["ngin_super_reg:0", "Ngin:cms"];

      window.SeMParticle.mergeToDL('platform', platformDL);
      window.SeMParticle.mergeToDL('quantcast', quantcastDL);
      window.SeMParticle.mergeToDL('elevioAddlGroups', elevioAdditionalGroups);

        window.SeMParticle.mergeToDL('apigatewayDomain', 'https://www.mnfootballhub.com/apigateway')

        window.SeMParticle.mergeToDL('ga_site_config', {
          'id': 'UA-179757955-6',
          'domains': ["www.mnfootballhub.com","mnfootballhub.sportngin.com"]
        });
    }
  })

</script>
<!-- End Google Tag Manager Data Layer -->

<script>
function inIframe() {
  try {
    return window.self !== window.top;
  } catch (e) {
    return true;
  }
}
</script>

<!-- Google Tag Manager for NGIN -->
<script>
if(!inIframe()) {
  (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
          new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
      j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
      'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-TMK6MGB');
}
</script>
<!-- End Google Tag Manager for NGIN-->

<!-- Google Tag Manager for SE Global -->
<script>
if(!inIframe()) {
  (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-KGG8ZWR');
}
</script>
<!-- End Google Tag Manager for SE Global -->


	<link rel="stylesheet" media="print" href="/stylesheets/print/website_print_v4.css?1634232131" />


<script type='text/javascript' src='/javascripts/jquery/jquery-1.7.1.min.js'></script>
<script type='text/javascript'>
  var $j = jQuery.noConflict();
</script>



<link href="//assets.ngin.com/site_files/268/_site/css/268_style.min.css" type="text/css" rel="stylesheet" media="screen" />
<script src="//assets.ngin.com/site_files/268/_site/js/268_script.min.js "></script>



<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6GwLjFYLCPGnq"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6GwLjFYLCPGnq.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<!-- Start Top Google Tag -->
<script type="text/javascript">
var hostDomain = 'www.startribune.com';
</script>
<script type="text/javascript">
  (function() {
	var useSSL = 'https:' == document.location.protocol;
	var src = (useSSL ? 'https:' : 'http:') +       '//www.googletagservices.com/tag/js/gpt.js';
	document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();
</script>


<!-- SiteCatalyst code version: H.20.3.

Copyright 1996-2009 Adobe, Inc. All Rights Reserved More info available at http://www.omniture.com --> 

<script type="text/javascript" src="https://www.startribune.com/analytics-assets/sitecatalyst/AppMeasurement.js"></script>

<script type="text/javascript" src="https://www.startribune.com/analytics-assets/sitecatalyst/StarTribunePageConfiguration.js"></script>

<script language="JavaScript" type="text/javascript">

if('undefined' != typeof stribUser){

	s.prop16 = stribUser;

}else{

	s.prop16 = "Not Logged In";

}



if('undefined' != typeof eEditionUser){

	s.prop19 = eEditionUser;

}else{

	s.prop19 = "Not Logged In";

}

s.linkInternalFilters = "javascript:mnfootballhub,mnfootballhub.com";

/* Conversion Variables */

s.campaign="";

s.state="";

s.zip="";

s.events="";

s.products="";

s.purchaseID="";

s.eVar1="";

s.eVar2="";

s.eVar3="";

s.eVar4="";

s.eVar5="";





	<!-- Shell for SiteCatalyst code version: F.1/G5 Copyright 2002 Omniture, Inc. -->



s.prop3 = "section front";

s.prop4 = "TST Media";

s.pageName = "MNFootballHub:" + document.title;

s.prop2 = "HTML";

s.server = "High School Hubs";

s.channel = "sports";

s.prop7 = "High Schools";

s.prop24="Football Hub";

		/* ============== Start Subscription tracking =======================*/

if (readCookie("usersubs")) {

    s.prop37 = readCookie("usersubs");

} 

/* ============== End Subscription tracking =======================*/		

	</script>

<script language="JavaScript" type="text/javascript">

		var s_code=s.t();

		if(s_code){

			document.write(s_code);

		}

</script>

<script language="JavaScript" type="text/javascript"><!--

if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')

//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img src="https://nandomedia.112.2o7.net/b/ss/nmminneapolis/1/H.20.3--NS/0?pageName=MNFootballHub&server=High%20School%20Hubs&channel=sports&c1=https://www.mnfootballhub.com/&c2=HTML&c3=section%20front&c4=TST%20Media&c5=noscript&c6=&c7=High%20Schools&c24=Football%20Hub"

height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->

<!-- End SiteCatalyst code version: H.20.3. -->
  <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.9/jquery-ui.min.js"></script>

<script src="/javascripts/base_packaged.js?1624378150"></script>
<script src="/javascripts/angular_packaged.js?1624378150"></script>

  <script src="/javascripts/dropdown_nav.js?1624378150"></script>


<script>
//<![CDATA[
              googletag.cmd.push(function() {
             pubads = googletag.pubads();
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_671463_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[300, 250], [234, 60], [125, 125], [180, 150], [250, 250], [120, 600], [160, 600]], "adel_671463_ad")
        .addService(googletag.pubads()).setTargeting("pos", "1").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_671464_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[300, 250], [300, 600], [234, 60], [125, 125], [180, 150], [250, 250], [120, 600]], "adel_671464_ad")
        .addService(googletag.pubads()).setTargeting("pos", "2").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_671465_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[300, 250]], "adel_671465_ad")
        .addService(googletag.pubads()).setTargeting("pos", "3").setTargeting("tile", "").setTargeting("ct", "f");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_671462_ad"] = googletag.defineOutOfPageSlot("/7932/website/web_sports/web_sports_preps/web_sports_preps_football/news-article/news", "adel_671462_ad")
        .addService(pubads).setTargeting("pos", "1").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["top_leaderboard_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[728, 90], [970, 250], [970, 90], [320, 50], [468, 60], [970, 30]], "top_leaderboard_ad")
        .addService(googletag.pubads()).setTargeting("pos", "1").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["bottom_leaderboard_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[728, 90], [970, 250], [970, 90], [320, 50], [468, 60], [970, 30], [970, 600]], "bottom_leaderboard_ad")
        .addService(googletag.pubads()).setTargeting("pos", "f1").setTargeting("tile", "").setTargeting("ct", "a");

        pubads.setTargeting("zone", "news");
    pubads.setTargeting("siteid", "1862");
    pubads.setTargeting("pagenodetags", ["338086", "342062", "6481573", "6481723"]);
    pubads.setTargeting("sport", ["football"]);
    pubads.setTargeting("controller", "news_article");
    pubads.setTargeting("pntn", ["home", "star-tribune", "mayer-lutheran", "minneota"]);

    

           googletag.enableServices();
    });


//]]>
</script>
  <link rel="stylesheet" href="//s3.amazonaws.com/sportngin-snap-production/ui_themes/inline-manual/1/main.css?20190108" type="text/css" />

  <script>
      window.inlineManualOptions = {
        tracking: {
          enabled: false
        }
      }
  </script>

  <script>
      NGIN.inlineManual.setVars({
        in_edit_mode: false,
        org_id: 1838,
        
        site_name: "MN Football Hub | High School Football News, Scores &amp; Standings",
        site_short_name: "MN Football Hub",
        site_url: "https://www.mnfootballhub.com",
        site_id: 1862
      });

  </script>

  <script>!function(){var e=document.createElement("script"),t=document.getElementsByTagName("script")[0];e.async=1,e.src="https://inlinemanual.com/embed/player.cacb2d9a339b3500c03525980ca2a24c.js",e.charset="UTF-8",t.parentNode.insertBefore(e,t)}();</script>



  



    <!-- news article head code logic -->

<script>
  var recaptchaSiteKey = "6LePJx8TAAAAACXrjU21ZdxvkXD_rh3yzhSeoJ0a"
</script>
<script src="/javascripts/grecaptcha.js?1624378150"></script>
<script src="https://www.google.com/recaptcha/api.js?onload=recaptchaOnloadCallback&render=explicit" async defer></script>


<script>
//<![CDATA[
  window.nginSite = {"domain_name":"mnfootballhub.com","subdomain":"www","name":"MN Football Hub | High School Football News, Scores \u0026 Standings","short_name":"MN Football Hub","secure_subdomain":"mnfootballhub"}

//]]>
</script>



  <script type="text/javascript" src="/javascripts/jquery/jquery.toolbar.min.js"></script>

  
    <link rel="canonical" href="https://www.mnfootballhub.com/news_article/show/1195811" />
  
      <meta property="og:type" content="article"/>
<meta property="og:title" content="Mayer Lutheran snags its first football state title, winning the Class 1A final"/>
<meta property="og:description" content="Minneota, in pursuit of its eighth championship, gave up two TDs in 20 seconds in the first half."/>
<meta property="og:url" content="https://www.mnfootballhub.com/news_article/show/1195811-mayer-lutheran-snags-its-first-football-state-title-winning-the-class-1a-final"/>
<meta property="og:site_name" content="MN Football Hub | High School Football News, Scores &amp; Standings"/>
<meta property="og:image" content="https://cdn4.sportngin.com/attachments/news_article/1b2d-167397845/1newer1afront_large.jpg"/>
<meta name="author" content="JIM PAULSEN, Star Tribune"/>
<meta property="article:published_time" content="2021-11-26T10:00:00-06:00"/>
<meta property="article:section" content="Sports"/>
    <meta property="article:tag" content="Football"/>

      <meta property="fb:app_id" content="207855525922791">


</head>

<body id="" class="site-body custom user_mode newsPage home v4" >
      <script>
//<![CDATA[
setTimeout(function() { window.SeMParticle.pageView(JSON.parse('{"depth1":"Sitebuilder","title":""}')) }, 500)
//]]>
</script>
<!-- Needs to be immediately after the opening <body> tag -->
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TMK6MGB"
                  height="0" width="0" style="display:none;visibility:hidden"></iframe>
  <iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KGG8ZWR"
          height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->

  


<style type="text/css">
  /* html must be relative to keep the background div sized */
  html { position: relative; }

  /* fix positioning issue with smart banner when html is relative */
  #smartbanner {
    position: fixed;
    box-sizing: content-box;
  }

  
</style>

<div class="site-background"></div>

      <ul id="accountNav">
      
        <li class="currentSite hasSiteLogo">
          <a title="MN Football Hub | High School Football News, Scores &amp; Standings Homepage" href="https://www.mnfootballhub.com"></a>
        </li>
        <li class='enabled' id='login'><span><a class="enabled" title="Login" href="https://login.sportngin.com">Login</a></span></li>
        <li class='secondary enabled' id='account_new'><span><a class="secondary enabled" title="Create an Account" href="https://user.sportngin.com/users/sign_up?user_return_to=https%3A%2F%2Flogin.sportngin.com%3Fnext_url%3Dhttps%253A%252F%252Fwww.mnfootballhub.com%252Fnews_article%252Fshow%252F1195811%26set_site_id%3D1862&amp;brand=">Create an Account</a></span></li>
      
      
      <li class="nginLogo"><a href="https://www.sportsengine.com/?utm_source=https://www.mnfootballhub.com&utm_medium=usertopnav&utm_campaign=applications" onclick="javascript:window.location=('https://www.sportsengine.com/?utm_source=https://www.mnfootballhub.com&utm_medium=usertopnav&utm_campaign=applications'); return false;">SportsEngine</a></li>




    </ul>

  
  <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  // js.src = "//connect.facebook.net/en_US/all/debug.js#xfbml=1&version=v2.3"; // use if debugging
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

  <a href="#yieldContent" style="color:#FFF;position:absolute;height:1px;width:1px;left:-9999px;">skip navigation</a>

  
  <!-- Google Tag Manager -->

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NBNKP6"

height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-NBNKP6');</script>

<!-- End Google Tag Manager -->



  
<div id="topNav" class="has-site-logo topNav">
  
    <div id="sn-site-logo">
  <a class="sn-site-logo-wrap" href="/">
    <span class="sn-site-logo-background" style="background-image: url(https://cdn1.sportngin.com/attachments/logo_graphic/9697/8984/football-hub_small.png);"></span>
  </a>
</div>

  
  <div class="theme-search-wrapper">
    <div class="theme-search-bar">
      
        <span class="site-tagline-text">
          
            MN Football Hub&nbsp; 
          
        </span>
      
      
      
        <div id="PageSearchBoxTopNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Team Finder" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit" >Search</span>
</div>

<script>
  new NGIN.PageSearchBox('#PageSearchBoxTopNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

      
      
        <div id="GoogleSearchBoxTopNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Content Search" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit">Search</span>
</div>

<script>
  new NGIN.GoogleSearchBox('#GoogleSearchBoxTopNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

      
    </div>
  </div>
  <div class="theme-main-nav"></div>
  <div class="theme-sub-nav"></div>
  <div class="theme-mobile-nav">
    
    
    
      <div id="PageSearchBoxMobileNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Team Finder" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit" >Search</span>
</div>

<script>
  new NGIN.PageSearchBox('#PageSearchBoxMobileNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

    
    
      <div id="GoogleSearchBoxMobileNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Content Search" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit">Search</span>
</div>

<script>
  new NGIN.GoogleSearchBox('#GoogleSearchBoxMobileNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

    
  </div>
</div>
<div id="topNavPlaceholder" class="page-has-banner"></div>

<script type="text/javascript">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</script>


  



  <style>
    .site-banner-wrapper {
      background-color: transparent;
    }

    
      .site-banner-wrapper {
        background-image: url(https://cdn4.sportngin.com/attachments/banner_graphic/9697/8981/siteHeader.jpg);
        background-position: center;
      }

      @media (max-width: 999px) {
        .site-banner-wrapper {
          min-height: 15.957447vw;
        }
      }

      @media (min-width: 1000px) {
        .site-banner-wrapper {
          min-height: 159.574468px;
        }
      }
    
  </style>

  <div id="siteHeader">
    

    <div class="site-banner-wrapper">
      <div class="site-banner-text-wrapper">
        

        
          <h1 style="color:#000000">MN Football Hub</h1>
        

        
          <h3 style="color:#000000"></h3>
        
      </div>
    </div>
  </div>



  <div id="siteContainer" class="container-fluid two_panel siteContainer">
    
      <div id="adWrapperTopLeaderboard" class="ad-wrapper top-leaderboard">
          <div class="adbox" style="width: 100%; text-align:center; padding-bottom: 10px">
          <div id="top_leaderboard_ad"><script type="text/javascript">              googletag.cmd.push(function() {
                googletag.display("top_leaderboard_ad");
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperTopLeaderboard');</script>

    

    

    <div id="yieldContent" class="row">
      
  
    
      <h2 id="displayBodyHeader" class=""><span></span></h2>
    
  



      <div id="panelTwo" class="col-sm-12">
        <div id="errorNotice">
  
  
  
  
  
</div>


        <div class='yieldPageContent'>
          
  




<div class=" newsItemColumn">

  <div class="column col-sm-12">
    <div class="newsItemElement pageElement">
      
      <img alt="" class="newsArticleThumbnail" src="https://cdn4.sportngin.com/attachments/news_article/1b2d-167397845/1newer1afront_thumb.jpg" title="1newer1afront.jpg">
      
      <h2 class="titleText">Mayer Lutheran snags its first football state title, winning the Class 1A final</h2>
      <p class="authorDetails">By <span class="newsAuthor">JIM PAULSEN, Star Tribune</span>, <span class="newsDate">11/26/21, 10:00AM  CST</span> </p>
      <span class="sn-share-icons">
        <div class="sn-share-text">Share</div>
        <div class="addthis_sharing_toolbox"></div>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b7e7311a76ae80" async="async"></script>
      </span>
      <hr>
      <h4 class="teaserText">Minneota, in pursuit of its eighth championship, gave up two TDs in 20 seconds in the first half.</h4>
      
      
      <div class="previewText"></div>
      
    </div>
  </div>
</div>


  

<div class="newsContentNode">      <div class="layoutContainer row layout-100 ">
    
          <div class="column-1 column col-sm-12 col-md-12">
        </div>
    <span class="clearAll"></span>
  </div>

      <div class="layoutContainer row layout-66-33 ">
    
          <div class="column-1 column col-sm-12 col-md-8">
                <div id="pageEl_535032415" class="pageEl"  >
  
        <div class="pageElement heroPhotoElement">

      <img src="https://cdn3.sportngin.com/attachments/photo/dec4-167397918/1anewestinside112721_large.jpg" alt="" />
    <br/>
      <p class="cutline">Mayer Lutheran&#39;s Tyler Neitzel (left), Elijah Jopp (7) and Cole Neitzel celebrated their championship. AARON LAVINSKY, Star Tribune</p>
  </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_534914121" class="pageEl"  >
  
      <div class="pageElement textBlockElement clearfix">
  
    <h3 style="text-align: left;"><span>First report</span></h3>


    <div class="text clearfix">
      <p>Mayer Lutheran got a 7-yard touchdown run from Cole Neitzel in the third quarter to take a six-point lead, then leaned on its defense to keep Minneota off the board for the rest of the game Friday, emerging with a 20-14 victory in the Class 1A championship game.</p>

<p>Quarterback Ty Hoese was 12-for-26 for 142 yards and a touchdown for Mayer Lutheran (13-1), which scored two touchdowns in a span of 20 seconds in the first half to turn a 7-0 deficit into a 13-7 lead.</p>

<p>Minneota went up 14-13 just before halftime on a 22-yard scoring reception by Jonah Gruenes, who carried at least three Mayer Lutheran tacklers into the end zone.</p>

<p>It&rsquo;s Mayer Lutheran&rsquo;s first state title, and it comes in its first trip to the Prep Bowl. Minneota (13-1) was seeking its eighth state championship.</p>

    </div>
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_534914146" class="pageEl"  >
  
    <script type="text/javascript">
      $j('#pageEl_534914146').load('/page_element/ajax/534914146' +
        '?width_percentage=66' +
        '&page_node_id=338086' +
        '&subseason=' +
        '&news_article_id=1195811' +
        '',
        function() {
          rebind_lbon()
          if ($j(".iframeHeader").length) {
            $j("body").trigger("resizeIframe")
          } else {
            $j("body").trigger("pageElementAjaxLoad")
          }
        });
    </script>
  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913889" class="pageEl feederTitle"  >
  
    <script type="text/javascript">
      $j('#pageEl_534913889').load('/page_element/ajax/534913889' +
        '?width_percentage=66' +
        '&page_node_id=338086' +
        '&subseason=' +
        '&news_article_id=1195811' +
        '',
        function() {
          rebind_lbon()
          if ($j(".iframeHeader").length) {
            $j("body").trigger("resizeIframe")
          } else {
            $j("body").trigger("pageElementAjaxLoad")
          }
        });
    </script>
  <span class="clearAll"></span>
</div>


        </div>
          <div class="column-2 column col-sm-12 col-md-4">
                <div id="pageEl_534913890" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement671463" class="ad-wrapper ad-element-671463">
          <div class="adbox" style="">
          <div id="adel_671463_ad"><script type="text/javascript">              googletag.cmd.push(function() {
                googletag.display("adel_671463_ad");
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement671463');</script>

</div>


  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913891" class="pageEl facebook-link"  >
  
      <div class="pageElement linkElement">
  <h4><a href="https://www.facebook.com/mnfootballhub/" target=_blank class="icon goToLink">MN Football Hub</a></h4>
  
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913892" class="pageEl twitter-link"  >
  
      <div class="pageElement linkElement">
  <h4><a href="https://twitter.com/mnfootballhub" target=_blank class="icon goToLink">@MNFootballHub</a></h4>
  
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913893" class="pageEl trim"  >
  
      <div class="pageElement aggregatorElement newsAggregatorElement">

      <h3 class="aggHeader"><span>Football Hub Headlines</span></h3>

      

    <div class="odd item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/1190741?referrer_id=338086"><img alt="" width="75" src="https://cdn3.sportngin.com/attachments/news_article/16be-166351509/Top_Performer_FB_reveal_Offense_small_thumb.jpeg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/1190741?referrer_id=338086">And the winner is...MN Football Hub offensive top performer revealed</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Kassondra Burtis, SportsEngine</span>
      <span class="newsDate">10/27/2021, 8:00am CDT </span>
    </li>
    <li class="teaser expandedView">See who fans voted as the top performer from Oct. 19-21.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/1190741?referrer_id=338086">Read More</a>
      </span>
      <span class="commentCount">
        <a href="https://www.mnfootballhub.com/news_article/show/1190741?referrer_id=338086#commentStreamComments" title="1 Comment" class="button-small button-commentCount">
          <span class="button-image-right"></span>
          <span class="button-content">
            1<span class="comment-label"> Comment</span>
          </span>
        </a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="even item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/1190742?referrer_id=338086"><img alt="" width="75" src="https://cdn1.sportngin.com/attachments/news_article/ae5c-166351596/Top_Performer_FB_reveal_defense_small_thumb.jpeg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/1190742?referrer_id=338086">And the winner is...MN Football Hub defensive top performer revealed</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Kassondra Burtis, SportsEngine</span>
      <span class="newsDate">10/27/2021, 8:00am CDT </span>
    </li>
    <li class="teaser expandedView">See who fans voted as the top performer from Oct. 19-21.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/1190742?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="odd item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/1189427?referrer_id=338086"><img alt="" width="75" src="https://cdn2.sportngin.com/attachments/news_article/9dc8-166005318/Top_Performer_FB_reveal_Offense_small_thumb.jpeg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/1189427?referrer_id=338086">And the winner is...MN Football Hub offensive top performer revealed</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Kassondra Burtis, SportsEngine</span>
      <span class="newsDate">10/18/2021, 9:00am CDT </span>
    </li>
    <li class="teaser expandedView">See who fans voted as the top performer from Oct. 14-16.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/1189427?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="even item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/1189428?referrer_id=338086"><img alt="" width="75" src="https://cdn1.sportngin.com/attachments/news_article/c6a0-166005368/Top_Performer_FB_reveal_defense_small_thumb.jpeg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/1189428?referrer_id=338086">And the winner is...MN Football Hub defensive top performer revealed</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Kassondra Burtis, SportsEngine</span>
      <span class="newsDate">10/18/2021, 9:00am CDT </span>
    </li>
    <li class="teaser expandedView">See who fans voted as the top performer from Oct. 14-16.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/1189428?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="odd item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/1188177?referrer_id=338086"><img alt="" width="75" src="https://cdn2.sportngin.com/attachments/news_article/5ef1-165710122/Top_Performer_FB_reveal_Offense_small_thumb.jpeg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/1188177?referrer_id=338086">And the winner is...MN Football Hub offensive top performer revealed</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Kassondra Burtis, SportsEngine</span>
      <span class="newsDate">10/12/2021, 9:30pm CDT </span>
    </li>
    <li class="teaser expandedView">See who fans voted as the top performer from Oct. 7-9.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/1188177?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


      <div class="extendedOptions item even" style="text-align:right;">
        <link href="/news_rss_feed?tags=338086,3904007,3904008,3904009,342062" rel="alternate" title="WWW News with Tags: Error" type="application/rss+xml" id="rssFeed" />
          <a class="goToLink icon" title="View All" href="https://www.mnfootballhub.com/page/show/484170?match_option=0&amp;news_aggregator=2760175&amp;tags=">View All</a>
      </div>

  </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913894" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement671464" class="ad-wrapper ad-element-671464">
          <div class="adbox" style="">
          <div id="adel_671464_ad"><script type="text/javascript">              googletag.cmd.push(function() {
                googletag.display("adel_671464_ad");
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement671464');</script>

</div>


  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913895" class="pageEl sn-title-sports open-links-in-new-window"  >
  
      <div id="feed_162890" class="pageElement aggregatorElement newsAggregatorElement ">
    <div id="feeder_162890" class="feeder">
  <h3 id="feeder_162890_title"><span>Feed for https://www.startribune.com/sports/index.rss2</span></h3>
  <div id="feeder_162890_items">
  </div>
  <div style="text-align: right; display:none;" class="extendedOptions item" id="feeder_162890_buttons">
    <a title="Refresh RSS Feed" class="reloadLink icon" href="#" onclick="new Ajax.Request(&#39;/feeder/rss_proxy/162890&#39;, { method: &#39;get&#39;, onSuccess: function(transport) { parse_rss_for_feeder(transport.responseXML, 162890,5); }});; return false;">Refresh</a>
    | <a class="rssLink icon" target="_blank" href="https://www.startribune.com/sports/index.rss2" title="Subscribe to RSS Feed">Subscribe</a>
  </div>
</div>
<script src="/javascripts/rss.js?1624378150"></script>
<script type="text/javascript">
  $j(function(){
      $j.ajax({
          url: '/feeder/rss_proxy/162890'
        }).success(function(r, status, xhr) {
          parse_rss_for_feeder(xhr.responseXML, xhr.responseText, 162890, 5)
      })
    });
</script>

  </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_534913896" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement671465" class="ad-wrapper ad-element-671465">
          <div class="adbox" style="">
          <div id="adel_671465_ad"><script type="text/javascript">              googletag.cmd.push(function() {
                googletag.display("adel_671465_ad");
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement671465');</script>

</div>


  <span class="clearAll"></span>
</div>


        </div>
    <span class="clearAll"></span>
  </div>

      <div class="layoutContainer row layout-100 ">
    
          <div class="column-1 column col-sm-12 col-md-12">
                <div id="pageEl_534913888" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement671462" class="ad-wrapper ad-element-671462">
          <div class="adbox" style="">
          <div id="adel_671462_ad"><script type="text/javascript">              googletag.cmd.push(function() {
                googletag.display("adel_671462_ad");
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement671462');</script>

</div>


  <span class="clearAll"></span>
</div>


        </div>
    <span class="clearAll"></span>
  </div>

      <div class="layoutContainer row layout-100 ">
    
          <div class="column-1 column col-sm-12 col-md-12">
        </div>
    <span class="clearAll"></span>
  </div>





</div>

  

<div class="column col-sm-12">
  <p class="newsTags pageElement">Tag(s):
          <a href="https://www.mnfootballhub.com/page/show/338086-home">Home</a>&nbsp;
      <a href="https://www.mnfootballhub.com/page/show/6481573-mayer-lutheran">Mayer Lutheran</a>&nbsp;
      <a href="https://www.mnfootballhub.com/page/show/6481723-minneota">Minneota</a>&nbsp;

  </p>
  <div class="bottomOptions">
    <div class="sharingOptions">
      <span class="sn-share-icons">
        <div class="sn-share-text">Share</div>
        <div class="addthis_sharing_toolbox"></div>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b7e7311a76ae80" async="async"></script>
      </span>
    </div>
    <ul class="pageOptions">
      <li><a href="javascript: history.go(-1)" class="goBackLink icon">Back to Previous Page</a></li>
      <li><a class="printLink icon" onclick="window.print()">Print This Page</a></li>
    </ul>
  </div>
</div>

  <script type="text/javascript">
  $j(document).ready(function() {
    $j.get("/news_article/visit/1195811")
  })
</script>



        </div>
      </div>
      
        <div id="adWrapperBottomLeaderboard" class="ad-wrapper bottom-leaderboard">
          <div class="adbox" style="">
          <div id="bottom_leaderboard_ad"><script type="text/javascript">              googletag.cmd.push(function() {
                googletag.display("bottom_leaderboard_ad");
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperBottomLeaderboard');</script>

      

    </div>
  </div>
  <footer class="snFooterContainer">
    <div id="siteFooter">
  
    
    
    <ul class="se-footer">
      <li class="se-footer-copyright">
        This website is powered by SportsEngine's
        <a class="legalLink" target="_blank" href="https://www.sportsengine.com/solutions/">
          Sports Relationship Management
        </a>
        (SRM) software, but is owned by and subject to the  MN Football Hub | High School Football News, Scores &amp; Standings privacy policy.
        <a class="legalLink" target="_blank" href="https://www.sportsengine.com/corp">
          &copy;2021 SportsEngine, Inc.
        </a>
        <br>
      </li>
      <li class="se-footer-link">
        <a class="legalLink" target="_blank" href="/privacy_policy.pdf">Privacy Policy</a>
      </li>
      <li id="poweredByNGIN" class="se-footer-logo" style="text-align: center;">
        <br>
        <a href="https://www.sportsengine.com/?utm_source=Sitebuilder&utm_medium=Footer&utm_campaign=SportsEngine+Internal+Link&utm_term=Footer"
           onclick="javascript:window.location=('https://www.sportsengine.com/?utm_source=Sitebuilder&utm_medium=Footer&utm_campaign=SportsEngine+Internal+Link&utm_term=Footer'); return false;">
          <img src="/logo_images/white_logo.png" alt="Powered by SportsEngine" title="Click here to learn how SportsEngine can empower your organization!">
        </a>
      </li>
    </ul>
</div>









  </footer>

  
    

<div id="PageSearch" class="theme-search-overlay" style="display:none;">
  <div class="theme-search-modal">
    <span class="theme-search-close"></span>
    <h1 class="theme-search-title">Team Finder</h1>
    <div class="theme-search-box">
      <input type="text" class="theme-search-input" />
      <span class="theme-search-clear"></span>
    </div>
    <div class="theme-search-results">
      <img class="theme-search-spinner" src="/app_images/loaderBarUserMode.gif" />
      <span class="theme-search-status"></span>
      <!-- search results here -->
    </div>
  </div>
</div>

<script type="text/javascript" charset="utf-8">
  new NGIN.PageSearchModal('#PageSearch', {
    inputElement: '.theme-search-input',
    statusElement: '.theme-search-status',
    spinnerElement: '.theme-search-spinner',
    clearElement: '.theme-search-clear',
    resultsElement: '.theme-search-results',
    closeElement: '.theme-search-close',
  });
</script>

  

  
    <div id="GoogleContentSearch" class="theme-search-overlay" style="display:none;">
  <div class="theme-search-modal">
    <span class="theme-search-close"></span>
    <h1 class="theme-search-title">Content Search</h1>
    <div class="theme-search-box">
      <gcse:searchbox gname="GoogleSearch"></gcse:searchbox>
    </div>
    <div class="theme-search-results">
      <gcse:searchresults gname="GoogleSearch"></gcse:searchresults>
    </div>
  </div>
</div>

<script type="text/javascript" charset="utf-8">
  new NGIN.GoogleSearchModal('#GoogleContentSearch', {
    closeElement: '.theme-search-close',
  });
</script>

<script>
  // Google Generated Code
  (function() {
    var cx = '011769658581138827714:9pvpnwiqiok';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>

  

</body>
</html>
