<!DOCTYPE html>
<html lang="en-us" id="ngin1862">
<head>
<!--[if lte IE 9]>
    <meta http-equiv="refresh" content="0; url=/unsupported_browser" />
    <script type="text/javascript">
        window.top.location = '/unsupported_browser';
    </script>
<![endif]-->
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"7b8dc0b815","applicationID":"16731","transactionName":"IQkMERZcXApQQRZeBBUVPQQWR1kFWVYWQwkNEQ==","queueTime":0,"applicationTime":29,"agent":""}</script>
<script type="text/javascript">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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1" />
  <meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="VCnUJzEFnOiMsQTRJzmZGgWjoZPuDdzjeU8OCc2Sq/Ljj4mguqOMq9RTPJmXcwOE4VF29HAedxG5oQq9KayBqA==" />
<meta name="trace-id" content="c755238d-3f88-4fbd-8326-ba99cfa51e27" />
  <title>First-quarter outburst enough for Edina to defeat No. 4 Minnetonka</title>

  <!-- Custom | application -->

  <!-- Icons v4 -->
<link rel="shortcut icon" href="https://assets.ngin.com/site_files/1862/favicon.ico" />


  <link href="https://cdn2.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_120.png" rel="apple-touch-icon" />
  <link href="https://cdn1.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_152.png" rel="apple-touch-icon" sizes="152x152" />
  <link href="https://cdn1.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_167.png" rel="apple-touch-icon" sizes="167x167" />
  <link href="https://cdn1.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_180.png" rel="apple-touch-icon" sizes="180x180" />
  <link href="https://cdn3.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_192.png" rel="icon" sizes="192x192" />
  <link href="https://cdn2.sportngin.com/attachments/touch_icon_graphic/9697/8998/touch-icon_size_128.png" rel="icon" sizes="128x128" />



  <link href="https://cdn1.sportngin.com/attachments/favicon_graphic/9697/9005/favicon_size_16.png" rel="icon" type="image/png" sizes="16x16">
  <link href="https://cdn2.sportngin.com/attachments/favicon_graphic/9697/9005/favicon_size_32.png" rel="icon" type="image/png" sizes="32x32">
  <link href="https://cdn2.sportngin.com/attachments/favicon_graphic/9697/9005/favicon_size_96.png" rel="icon" type="image/png" sizes="96x96">



  <meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mnfootballhub" />
<meta name="twitter:creator" content="@mnfootballhub" />
<meta property="og:description" content="The official home of Minnesota high school football." />
<meta name="description" content="Follow the MN Football Hub for complete Star Tribune coverage of high school football and the Minnesota state high school tournament, including scores, schedules, rankings, statistics and more."/>

  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1862/custom/page_elements.css?1537820323" />
  
    <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1862/custom/sports.css?1537820323" />
  
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1862/custom/default.css?1537820323" />
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/jquery_treeTable.css?1537820323" />
  <link rel="stylesheet" media="screen" href="/stylesheets/sn/shared_components.css?1537820323" />
  <link rel="stylesheet" media="screen" href="//s3.amazonaws.com/sportngin-snap-production/ui_themes/ngin/latest/ngin-bar.css" />

  
  <!--[if IE 9]>
  <script type="text/javascript" charset="utf-8">var IE = "9";</script>
  <link rel="stylesheet" media="screen" href="/stylesheets/ie9/default_ie9.css?1537820323" />
<![endif]-->

<!--[if IE 8]>
  <script type="text/javascript" charset="utf-8">var IE = "8";</script>
<![endif]-->

<!--[if IE 7]>
  <script type="text/javascript" charset="utf-8">var IE = "7";</script>
<![endif]-->

<!--[if IE 6]>
  <script type="text/javascript" charset="utf-8">var IE = "6";</script>
<![endif]-->

<!--[if lte IE 6]>
  <script type="text/javascript" charset="utf-8">var IE = "6";</script>
<![endif]-->

<!--[if !IE]><!--><script type="text/javascript" charset="utf-8">var IE = null;</script><!-- <![endif]-->


  
  	<link rel="stylesheet" media="print" href="/stylesheets/print/website_print_v4.css?1537820323" />


<script type='text/javascript' src='/javascripts/jquery/jquery-1.7.1.min.js'></script>
<script type='text/javascript'>
  var $j = jQuery.noConflict();
</script>



<link href="//assets.ngin.com/site_files/268/_site/css/268_style.min.css" type="text/css" rel="stylesheet" media="screen" />
<script src="//assets.ngin.com/site_files/268/_site/js/268_script.min.js "></script>



<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6GwLjFYLCPGnq"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6GwLjFYLCPGnq.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<!-- Start Top Google Tag -->
<script type="text/javascript">
var hostDomain = 'www.startribune.com';
</script>
<script type="text/javascript">
  (function() {
	var useSSL = 'https:' == document.location.protocol;
	var src = (useSSL ? 'https:' : 'http:') +       '//www.googletagservices.com/tag/js/gpt.js';
	document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();
</script>


<!-- SiteCatalyst code version: H.20.3.

Copyright 1996-2009 Adobe, Inc. All Rights Reserved More info available at http://www.omniture.com --> 

<script language="JavaScript" type="text/javascript" src="https://www.startribune.com/includes/omniture.H.20.3.js"></script>

<script language="JavaScript" type="text/javascript">

if('undefined' != typeof stribUser){

	s.prop16 = stribUser;

}else{

	s.prop16 = "Not Logged In";

}



if('undefined' != typeof eEditionUser){

	s.prop19 = eEditionUser;

}else{

	s.prop19 = "Not Logged In";

}



/* Conversion Variables */

s.campaign="";

s.state="";

s.zip="";

s.events="";

s.products="";

s.purchaseID="";

s.eVar1="";

s.eVar2="";

s.eVar3="";

s.eVar4="";

s.eVar5="";





	<!-- Shell for SiteCatalyst code version: F.1/G5 Copyright 2002 Omniture, Inc. -->



s.prop3 = "section front";

s.prop4 = "TST Media";

s.pageName = "MNFootballHub:" + document.title;

s.prop2 = "HTML";

s.server = "High School Hubs";

s.channel = "sports";

s.prop7 = "High Schools";

s.prop24="Football Hub";

		/* ============== Start Subscription tracking =======================*/

if (readCookie("usersubs")) {

    s.prop37 = readCookie("usersubs");

} 

/* ============== End Subscription tracking =======================*/		

	</script>

<script language="JavaScript" type="text/javascript">

		var s_code=s.t();

		if(s_code){

			document.write(s_code);

		}

</script>

<script language="JavaScript" type="text/javascript"><!--

if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')

//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img src="https://nandomedia.112.2o7.net/b/ss/nmminneapolis/1/H.20.3--NS/0?pageName=MNFootballHub&server=High%20School%20Hubs&channel=sports&c1=https://www.mnfootballhub.com/&c2=HTML&c3=section%20front&c4=TST%20Media&c5=noscript&c6=&c7=High%20Schools&c24=Football%20Hub"

height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->

<!-- End SiteCatalyst code version: H.20.3. -->
  <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.9/jquery-ui.min.js"></script>

<script src="/javascripts/base_packaged.js?1538750500"></script>
<script src="/javascripts/angular_packaged.js?1538750500"></script>

  <script src="/javascripts/dropdown_nav.js?1538750500"></script>


<script>
//<![CDATA[
              googletag.cmd.push(function() {
             pubads = googletag.pubads();
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_630419_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[300, 250], [234, 60], [125, 125], [180, 150], [250, 250], [120, 600], [160, 600]], "adel_630419_ad")
        .addService(googletag.pubads()).setTargeting("pos", "1").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_630420_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[300, 250], [300, 600], [234, 60], [125, 125], [180, 150], [250, 250], [120, 600]], "adel_630420_ad")
        .addService(googletag.pubads()).setTargeting("pos", "2").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_630421_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[300, 250]], "adel_630421_ad")
        .addService(googletag.pubads()).setTargeting("pos", "3").setTargeting("tile", "").setTargeting("ct", "f");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["adel_630418_ad"] = googletag.defineOutOfPageSlot("/7932/website/web_sports/web_sports_preps/web_sports_preps_football/news-article/news", "adel_630418_ad")
        .addService(pubads).setTargeting("pos", "1").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["top_leaderboard_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[728, 90], [970, 250], [970, 90], [320, 50], [468, 60], [970, 30]], "top_leaderboard_ad")
        .addService(googletag.pubads()).setTargeting("pos", "1").setTargeting("tile", "").setTargeting("ct", "a");
NGIN.adSlots = NGIN.adSlots || {};
      NGIN.adSlots["bottom_leaderboard_ad"] = googletag.defineSlot("/7932/website/web_sports/web_sports_preps/WEB_Sports_Preps_Football/news-article/news", [[728, 90], [970, 250], [970, 90], [320, 50], [468, 60], [970, 30], [970, 600]], "bottom_leaderboard_ad")
        .addService(googletag.pubads()).setTargeting("pos", "f1").setTargeting("tile", "").setTargeting("ct", "a");

        pubads.setTargeting("zone", "news");
    pubads.setTargeting("siteid", "1862");
    pubads.setTargeting("pagenodetags", ["3904007", "4199357", "4199359"]);
    pubads.setTargeting("sport", ["football"]);
    pubads.setTargeting("controller", "news_article");
    pubads.setTargeting("pntn", ["featured-news", "edina", "minnetonka"]);

    

           googletag.enableServices();
    });


//]]>
</script>
  <link rel="stylesheet" href="//s3.amazonaws.com/sportngin-snap-production/ui_themes/inline-manual/1/main.css" type="text/css" />

  <script>
      window.inlineManualOptions = {
        tracking: {
          enabled: false
        }
      }
  </script>

  <script>
      NGIN.inlineManual.setVars({
        in_edit_mode: false,
        org_id: 1838,
        
        site_name: "MN Football Hub | High School Football News, Scores &amp; Standings",
        site_short_name: "MN Football Hub",
        site_url: "https://www.mnfootballhub.com",
        site_id: 1862
      });

  </script>

  <script>!function(){var e=document.createElement("script"),t=document.getElementsByTagName("script")[0];e.async=1,e.src="https://inlinemanual.com/embed/player.cacb2d9a339b3500c03525980ca2a24c.js",e.charset="UTF-8",t.parentNode.insertBefore(e,t)}();</script>



  



    <!-- news article head code logic -->

  <style>.async-hide { opacity: 0 !important} </style>
  <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-821370-1', 'auto', {'allowLinker': true});
    ga('set', 'dimension2', 'football');
    ga('set', 'dimension3', '1862');
    ga('set', 'dimension4', 'MN');
    ga('require', 'linker');
    ga('linker:autoLink', ['www.mnfootballhub.com', 'mnfootballhub.sportngin.com']);
    ga('send', 'pageview');

          ga('create', 'UA-22325453-21', 'auto', {'name': 'siteTracker', 'allowLinker': true});
          ga('siteTracker.require', 'linker');
          ga('siteTracker.linker:autoLink', ['www.mnfootballhub.com', 'mnfootballhub.sportngin.com']);
          ga('siteTracker.send', 'pageview');
    </script>
    <!-- Quantcast Tag, part 1 -->
    <script type="text/javascript">
      var _qevents = _qevents || [];

      (function() {
        var elem = document.createElement('script');

        elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem, scpt);
      })();
    </script>


<script>
  var recaptchaSiteKey = "6LePJx8TAAAAACXrjU21ZdxvkXD_rh3yzhSeoJ0a"
</script>
<script src="/javascripts/grecaptcha.js?1538750500"></script>
<script src="https://www.google.com/recaptcha/api.js?onload=recaptchaOnloadCallback&render=explicit" async defer></script>


<script>
//<![CDATA[
  window.nginSite = {"domain_name":"mnfootballhub.com","subdomain":"www","name":"MN Football Hub | High School Football News, Scores \u0026 Standings","short_name":"MN Football Hub","secure_subdomain":"mnfootballhub"}

//]]>
</script>



  <script type="text/javascript" src="/javascripts/jquery/jquery.toolbar.min.js"></script>

  
    <link rel="canonical" href="https://www.mnfootballhub.com/news_article/show/955957" />
  
      <meta property="og:type" content="article"/>
<meta property="og:title" content="First-quarter outburst enough for Edina to defeat No. 4 Minnetonka"/>
<meta property="og:description" content="The sixth-ranked Hornets scored three touchdowns, more than they had scored in any game all season, and held on for a 21-7 victory."/>
<meta property="og:url" content="https://www.mnfootballhub.com/news_article/show/955957-first-quarter-outburst-enough-for-edina-to-defeat-no-4-minnetonka"/>
<meta property="og:site_name" content="MN Football Hub | High School Football News, Scores &amp; Standings"/>
<meta property="og:image" content="https://cdn4.sportngin.com/attachments/news_article/8ccf-111429675/edinacav1_large.jpg"/>
<meta name="author" content="JIM PAULSEN, Star Tribune"/>
<meta property="article:published_time" content="2018-10-05T21:15:00-05:00"/>
<meta property="article:section" content="Sports"/>
    <meta property="article:tag" content="Football"/>

      <meta property="fb:app_id" content="207855525922791">


</head>

<body id="" class="custom user_mode newsPage home v4" >

  


<style type="text/css">
  /* html must be relative to keep the background div sized */
  html { position: relative; }

  /* fix positioning issue with smart banner when html is relative */
  #smartbanner {
    position: fixed;
    box-sizing: content-box;
  }

  
</style>

<div class="site-background"></div>

  <ul id="accountNav">
  
    <li class="currentSite hasSiteLogo">
      <a title="MN Football Hub | High School Football News, Scores &amp; Standings Homepage" href="https://www.mnfootballhub.com"></a>
    </li>
    <li class='enabled' id='login'><span><a class="enabled" title="Login" href="https://login.sportngin.com">Login</a></span></li>
    <li class='secondary enabled' id='account_new'><span><a class="secondary enabled" title="Create an Account" href="https://user.sportngin.com/users/sign_up?user_return_to=https%3A%2F%2Flogin.sportngin.com%3Fnext_url%3Dhttps%253A%252F%252Fwww.mnfootballhub.com%252Fnews_article%252Fshow%252F955957%26set_site_id%3D1862&amp;brand=">Create an Account</a></span></li>
  
  
  <li class="nginLogo"><a href="https://www.sportsengine.com/?utm_source=https://www.mnfootballhub.com&utm_medium=usertopnav&utm_campaign=applications" onclick="javascript:window.location=('https://www.sportsengine.com/?utm_source=https://www.mnfootballhub.com&utm_medium=usertopnav&utm_campaign=applications'); return false;">SportsEngine</a></li>



</ul>

  
  <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  // js.src = "//connect.facebook.net/en_US/all/debug.js#xfbml=1&version=v2.3"; // use if debugging
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

  <a href="#yieldContent" style="color:#FFF;position:absolute;height:1px;width:1px;left:-9999px;">skip navigation</a>

  
  <!-- Google Tag Manager -->

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NBNKP6"

height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-NBNKP6');</script>

<!-- End Google Tag Manager -->



  
<div id="topNav" class="has-site-logo topNav">
  
    <div id="sn-site-logo">
  <a class="sn-site-logo-wrap" href="/">
    <span class="sn-site-logo-background" style="background-image: url(https://cdn1.sportngin.com/attachments/logo_graphic/9697/8984/football-hub_small.png);"></span>
  </a>
</div>

  
  <div class="theme-search-wrapper">
    <div class="theme-search-bar">
      
        <span class="site-tagline-text">
          
            MN Football Hub&nbsp; 
          
        </span>
      
      
      
        <div id="PageSearchBoxTopNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Team Finder" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit" >Search</span>
</div>

<script>
  new NGIN.PageSearchBox('#PageSearchBoxTopNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

      
      
        <div id="GoogleSearchBoxTopNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Content Search" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit">Search</span>
</div>

<script>
  new NGIN.GoogleSearchBox('#GoogleSearchBoxTopNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

      
    </div>
  </div>
  <div class="theme-main-nav"></div>
  <div class="theme-sub-nav"></div>
  <div class="theme-mobile-nav">
    
    
    
      <div id="PageSearchBoxMobileNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Team Finder" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit" >Search</span>
</div>

<script>
  new NGIN.PageSearchBox('#PageSearchBoxMobileNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

    
    
      <div id="GoogleSearchBoxMobileNav" class="theme-search-box">
  <input class="theme-search-input" type="text" placeholder="Content Search" />
  <span class="theme-search-clear"></span>
  <span class="theme-search-submit">Search</span>
</div>

<script>
  new NGIN.GoogleSearchBox('#GoogleSearchBoxMobileNav', {
    inputElement: '.theme-search-input',
    submitElement: '.theme-search-submit',
    clearElement: '.theme-search-clear'
  });
</script>

    
  </div>
</div>
<div id="topNavPlaceholder" class="page-has-banner"></div>

<script type="text/javascript">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</script>


  



  <style>
    .site-banner-wrapper {
      background-color: transparent;
    }

    
      .site-banner-wrapper {
        background-image: url(https://cdn4.sportngin.com/attachments/banner_graphic/9697/8981/siteHeader.jpg);
        background-position: center;
      }

      @media (max-width: 999px) {
        .site-banner-wrapper {
          min-height: 15.957447vw;
        }
      }

      @media (min-width: 1000px) {
        .site-banner-wrapper {
          min-height: 159.574468px;
        }
      }
    
  </style>

  <div id="siteHeader">
    

    <div class="site-banner-wrapper">
      <div class="site-banner-text-wrapper">
        

        
          <h1 style="color:#000000">MN Football Hub</h1>
        

        
          <h3 style="color:#000000"></h3>
        
      </div>
    </div>
  </div>



  <div id="siteContainer" class="container-fluid two_panel siteContainer">
    
      <div id="adWrapperTopLeaderboard" class="ad-wrapper top-leaderboard">
          <div class="adbox" style="width: 100%; text-align:center; padding-bottom: 10px">
          <div id="top_leaderboard_ad"><script type="text/javascript">
              googletag.cmd.push(function() {
                var adSlot = NGIN.adSlots["top_leaderboard_ad"];
                if (adSlot.rendered) {
                  pubads.refresh([adSlot]);
                } else {
                  googletag.display("top_leaderboard_ad");
                  adSlot.rendered = true;
                }
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperTopLeaderboard');</script>

    

    

    <div id="yieldContent" class="row">
      
  
    
      <h2 id="displayBodyHeader" class=""><span></span></h2>
    
  



      <div id="panelTwo" class="col-sm-12">
        <div id="errorNotice">
  
  
  
  
  
</div>


        <div class='yieldPageContent'>
          
  




<div class=" newsItemColumn">

  <div class="column col-sm-12">
    <div class="newsItemElement pageElement">
      
      <img alt="" class="newsArticleThumbnail" src="https://cdn2.sportngin.com/attachments/news_article/8ccf-111429675/edinacav1_thumb.jpg" title="edinacav1.jpg">
      
      <h2 class="titleText">First-quarter outburst enough for Edina to defeat No. 4 Minnetonka</h2>
      <p class="authorDetails">By <span class="newsAuthor">JIM PAULSEN, Star Tribune</span>, <span class="newsDate">10/05/18,  9:15PM  CDT</span> </p>
      <span class="sn-share-icons">
        <div class="sn-share-text">Share</div>
        <div class="addthis_sharing_toolbox"></div>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b7e7311a76ae80" async="async"></script>
      </span>
      <hr>
      <h4 class="teaserText">The sixth-ranked Hornets scored three touchdowns, more than they had scored in any game all season, and held on for a 21-7 victory.</h4>
      
      
      <div class="previewText"></div>
      
    </div>
  </div>
</div>


  

<div class="newsContentNode">      <div class="layoutContainer row layout-100 ">
    
          <div class="column-1 column col-sm-12 col-md-12">
        </div>
    <span class="clearAll"></span>
  </div>

      <div class="layoutContainer row layout-66-33 ">
    
          <div class="column-1 column col-sm-12 col-md-8">
                <div id="pageEl_427496423" class="pageEl"  >
  
        <div class="pageElement heroPhotoElement">

      <img src="https://cdn3.sportngin.com/attachments/photo/50ef-111429691/edinacav1_large.jpg" alt="" />
    <br/>
      <p class="cutline">On the first drive of the game, Edina&#39;s Matt Cavanagh (34) broke a tackle attempt by Minnetonka cornerback JJ Schechtman (8), opening up a path the the end zone for a touchdown. Photo: Aaron Lavinsky * aaron.lavinsky@startribune.com</p>
  </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327082" class="pageEl"  >
  
    <script type="text/javascript">
      $j('#pageEl_427327082').load('/page_element/ajax/427327082' +
        '?width_percentage=66' +
        '&page_node_id=338086' +
        '&subseason=' +
        '&news_article_id=955957' +
        '',
        function() {
          rebind_lbon()
          if ($j(".iframeHeader").length) {
            $j("body").trigger("resizeIframe")
          } else {
            $j("body").trigger("pageElementAjaxLoad")
          }
        });
    </script>
  <span class="clearAll"></span>
</div>


                <div id="pageEl_427495549" class="pageEl"  >
  
      <div class="pageElement textBlockElement clearfix">
  
    <h3 style="text-align: left;"><span>First report</span></h3>


    <div class="text clearfix">
      <p>Edina scored 21 points in the first quarter &ndash; more than it had scored in any game this season &ndash; then held on to defeat mistake-prone Minnetonka 21-7.</p>

<p>Matt Cavanagh scored on a 68-yard run on Edina&rsquo;s second play from scrimmage Friday at Kuhlman Stadium, igniting the Hornets&rsquo; three-touchdown outburst. Cavanagh finished with 156 yards and two touchdowns running for Edina (5-1).</p>

<p>Minnetonka (4-2) contributed to the Hornets&#39; early lead, sandwiching a pair of fumbles around back-to-back three-and-out possessions.</p>

<p>Check back later for more on the game.</p>

    </div>
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327066" class="pageEl feederTitle"  >
  
    <script type="text/javascript">
      $j('#pageEl_427327066').load('/page_element/ajax/427327066' +
        '?width_percentage=66' +
        '&page_node_id=338086' +
        '&subseason=' +
        '&news_article_id=955957' +
        '',
        function() {
          rebind_lbon()
          if ($j(".iframeHeader").length) {
            $j("body").trigger("resizeIframe")
          } else {
            $j("body").trigger("pageElementAjaxLoad")
          }
        });
    </script>
  <span class="clearAll"></span>
</div>


        </div>
          <div class="column-2 column col-sm-12 col-md-4">
                <div id="pageEl_427327067" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement630419" class="ad-wrapper ad-element-630419">
          <div class="adbox" style="">
          <div id="adel_630419_ad"><script type="text/javascript">
              googletag.cmd.push(function() {
                var adSlot = NGIN.adSlots["adel_630419_ad"];
                if (adSlot.rendered) {
                  pubads.refresh([adSlot]);
                } else {
                  googletag.display("adel_630419_ad");
                  adSlot.rendered = true;
                }
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement630419');</script>

</div>


  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327068" class="pageEl facebook-link"  >
  
      <div class="pageElement linkElement">
  <h4><a href="https://www.facebook.com/mnfootballhub/" target=_blank class="icon goToLink">MN Football Hub</a></h4>
  
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327069" class="pageEl twitter-link"  >
  
      <div class="pageElement linkElement">
  <h4><a href="https://twitter.com/mnfootballhub" target=_blank class="icon goToLink">@MNFootballHub</a></h4>
  
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327070" class="pageEl trim"  >
  
      <div class="pageElement aggregatorElement newsAggregatorElement">

      <h3 class="aggHeader"><span>Football Hub Headlines</span></h3>

      

    <div class="odd item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/955955?referrer_id=338086"><img alt="" width="75" src="https://cdn2.sportngin.com/attachments/news_article/91eb-111429894/woodwbl1_thumb.jpg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/955955?referrer_id=338086">Second-half opening kick return touchdown propels Woodbury past White Bear Lake</a></h4></li>
    <li class="dateAuthor futureDate">
      <span class="newsAuthor">By DAVID LA VAQUE, Star Tribune</span>
      <span class="newsDate">10/05/2018, 9:30pm CDT </span>
    </li>
    <li class="teaser expandedView">A 94-yard return by senior running back Andrew Kraemer broke a 7-7 halftime tie as the Royals cruised to a 33-15 victory.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/955955?referrer_id=338086">Read More</a>
      </span>
      <span class="commentCount">
        <a href="https://www.mnfootballhub.com/news_article/show/955955?referrer_id=338086#commentStreamComments" title="2 Comments" class="button-small button-commentCount">
          <span class="button-image-right"></span>
          <span class="button-content">
            2<span class="comment-label"> Comments</span>
          </span>
        </a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="even item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/955952?referrer_id=338086"><img alt="" width="75" src="https://cdn1.sportngin.com/attachments/news_article/7bd7-111429372/20181005_Chaska_Waconia_Scroll-9424_thumb.jpg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/955952?referrer_id=338086">Waconia shuts out Chaska as stingy defense continues to shine</a></h4></li>
    <li class="dateAuthor futureDate">
      <span class="newsAuthor">By HANK LONG, Special to the Star Tribune</span>
      <span class="newsDate">10/05/2018, 9:00pm CDT </span>
    </li>
    <li class="teaser expandedView">The Wildcats got three first-half field goals from Tim Stapleton en route to a 16-0 victory. </li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/955952?referrer_id=338086">Read More</a>
      </span>
      <span class="commentCount">
        <a href="https://www.mnfootballhub.com/news_article/show/955952?referrer_id=338086#commentStreamComments" title="5 Comments" class="button-small button-commentCount">
          <span class="button-image-right"></span>
          <span class="button-content">
            5<span class="comment-label"> Comments</span>
          </span>
        </a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="odd item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/955951?referrer_id=338086"><img alt="" width="75" src="https://cdn2.sportngin.com/attachments/news_article/000b-111425726/DSC09209_thumb.jpg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/955951?referrer_id=338086">Spectrum stays perfect, defeats St. Agnes</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By HEATHER RULE, Special to the Star Tribune</span>
      <span class="newsDate">10/05/2018, 5:30pm CDT </span>
    </li>
    <li class="teaser expandedView">The Sting&#39;s Fisher Marberg rushed for three touchdowns in the first half and later threw a scoring pass en route to a 42-7 victory.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/955951?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="even item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/956029?referrer_id=338086"><img alt="" width="75" src="https://cdn1.sportngin.com/attachments/news_article/0c9c-111431368/DSC_3727_thumb.jpg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/956029?referrer_id=338086">Holy Angels puts up 20 fourth-quarter points, flies past Benilde-St. Margaret's</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Blaze Fugina, SportsEngine</span>
      <span class="newsDate">10/04/2018, 10:15pm CDT </span>
    </li>
    <li class="teaser expandedView">The Stars&#39; Thomas Shelstad and Rook Rowe combined for four rushing touchdowns.</li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/956029?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


    <div class="odd item condensed">
    <a href="https://www.mnfootballhub.com/news_article/show/956026?referrer_id=338086"><img alt="" width="75" src="https://cdn3.sportngin.com/attachments/news_article/c12d-111429614/3632_thumb.jpg" /></a>
    <ul class="details">
    <li><h4><a class="" href="https://www.mnfootballhub.com/news_article/show/956026?referrer_id=338086">Orono rallies to tie game in regulation, defeats St. Louis Park in OT</a></h4></li>
    <li class="dateAuthor">
      <span class="newsAuthor">By Adam Holt, SportsEngine</span>
      <span class="newsDate">10/04/2018, 10:00pm CDT </span>
    </li>
    <li class="teaser expandedView"></li>
    <li class="commentsAndMore expandedView">
      <span class="readMore">
        <a class="button-small" href="https://www.mnfootballhub.com/news_article/show/956026?referrer_id=338086">Read More</a>
      </span>
    </li>
  </ul>
  <span class="clearAll"></span>
</div>


      <div class="extendedOptions item even" style="text-align:right;">
        <link href="/news_rss_feed?tags=338086,3904007,3904008,3904009,342062" rel="alternate" title="WWW News with Tags: Error" type="application/rss+xml" id="rssFeed" />
          <a class="goToLink icon" title="View All" href="https://www.mnfootballhub.com/page/show/484170?match_option=0&amp;news_aggregator=1969742&amp;tags=">View All</a>
      </div>

  </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327071" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement630420" class="ad-wrapper ad-element-630420">
          <div class="adbox" style="">
          <div id="adel_630420_ad"><script type="text/javascript">
              googletag.cmd.push(function() {
                var adSlot = NGIN.adSlots["adel_630420_ad"];
                if (adSlot.rendered) {
                  pubads.refresh([adSlot]);
                } else {
                  googletag.display("adel_630420_ad");
                  adSlot.rendered = true;
                }
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement630420');</script>

</div>


  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327072" class="pageEl sn-title-sports open-links-in-new-window"  >
  
      <div id="feed_82059" class="pageElement aggregatorElement ">
    <div id="feeder_82059" class="feeder">
  <h3 id="feeder_82059_title"><span>Feed for https://www.startribune.com/sports/index.rss2</span></h3>
  <div id="feeder_82059_items">
  </div>
  <div style="text-align: right; display:none;" class="extendedOptions item" id="feeder_82059_buttons">
    <a title="Refresh RSS Feed" class="reloadLink icon" href="#" onclick="new Ajax.Request(&#39;/feeder/rss_proxy/82059&#39;, { method: &#39;get&#39;, onSuccess: function(transport) { parse_rss_for_feeder(transport.responseXML, 82059,5); }});; return false;">Refresh</a>
    | <a class="rssLink icon" target="_blank" href="https://www.startribune.com/sports/index.rss2" title="Subscribe to RSS Feed">Subscribe</a>
  </div>
</div>
<script src="/javascripts/rss.js?1538750500"></script>
<script type="text/javascript">
  $j(function(){
      $j.ajax({
          url: '/feeder/rss_proxy/82059'
        }).success(function(r, status, xhr) {
          parse_rss_for_feeder(xhr.responseXML, xhr.responseText, 82059, 5)
      })
    });
</script>

  </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_427327074" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement630421" class="ad-wrapper ad-element-630421">
          <div class="adbox" style="">
          <div id="adel_630421_ad"><script type="text/javascript">
              googletag.cmd.push(function() {
                var adSlot = NGIN.adSlots["adel_630421_ad"];
                if (adSlot.rendered) {
                  pubads.refresh([adSlot]);
                } else {
                  googletag.display("adel_630421_ad");
                  adSlot.rendered = true;
                }
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement630421');</script>

</div>


  <span class="clearAll"></span>
</div>


        </div>
    <span class="clearAll"></span>
  </div>

      <div class="layoutContainer row layout-100 ">
    
          <div class="column-1 column col-sm-12 col-md-12">
                <div id="pageEl_427327065" class="pageEl"  >
  
    <div class="pageElement adElement">
   <div id="adWrapperAdElement630418" class="ad-wrapper ad-element-630418">
          <div class="adbox" style="">
          <div id="adel_630418_ad"><script type="text/javascript">
              googletag.cmd.push(function() {
                var adSlot = NGIN.adSlots["adel_630418_ad"];
                if (adSlot.rendered) {
                  pubads.refresh([adSlot]);
                } else {
                  googletag.display("adel_630418_ad");
                  adSlot.rendered = true;
                }
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperAdElement630418');</script>

</div>


  <span class="clearAll"></span>
</div>


        </div>
    <span class="clearAll"></span>
  </div>

      <div class="layoutContainer row layout-100 ">
    
          <div class="column-1 column col-sm-12 col-md-12">
        </div>
    <span class="clearAll"></span>
  </div>





</div>

  

<div class="column col-sm-12">
  <p class="newsTags pageElement">Tag(s):
          <a href="https://www.mnfootballhub.com/page/show/4199357-edina">Edina</a>&nbsp;
      <a href="https://www.mnfootballhub.com/page/show/4199359-minnetonka">Minnetonka</a>&nbsp;

  </p>
  <div class="bottomOptions">
    <div class="sharingOptions">
      <span class="sn-share-icons">
        <div class="sn-share-text">Share</div>
        <div class="addthis_sharing_toolbox"></div>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b7e7311a76ae80" async="async"></script>
      </span>
    </div>
    <ul class="pageOptions">
      <li><a href="javascript: history.go(-1)" class="goBackLink icon">Back to Previous Page</a></li>
      <li><a class="printLink icon" href="javascript:window.print()">Print This Page</a></li>
    </ul>
  </div>
</div>

  <script type="text/javascript">
  $j(document).ready(function() {
    $j.get("/news_article/visit/955957")
  })
</script>



        </div>
      </div>
      
        <div id="adWrapperBottomLeaderboard" class="ad-wrapper bottom-leaderboard">
          <div class="adbox" style="">
          <div id="bottom_leaderboard_ad"><script type="text/javascript">
              googletag.cmd.push(function() {
                var adSlot = NGIN.adSlots["bottom_leaderboard_ad"];
                if (adSlot.rendered) {
                  pubads.refresh([adSlot]);
                } else {
                  googletag.display("bottom_leaderboard_ad");
                  adSlot.rendered = true;
                }
              });
</script></div>
        </div>

</div>
<script type="text/javascript">new NGIN.AdResizer('#adWrapperBottomLeaderboard');</script>

      

    </div>
  </div>
  <footer class="snFooterContainer">
    
<div id="siteFooter">
  
    
    
    <ul>
      <li>&copy;2018 MN Football Hub | High School Football News, Scores &amp; Standings / <a href="https://sportsengine.com/?lead_source=SportsEngine%20Platform&utm_source=footerlogo" >SportsEngine</a>. All Rights Reserved.</li>
      <li><a class="legalLink" href="/legal/terms_of_use">Terms of Use</a></li>
        <li><a class="legalLink" href="https://www.sportsengine.com/legal/privacy_policy">Privacy Policy</a></li>
      <li></li>
      <li></li>
      <li id="poweredByNGIN"><a href="https://www.sportsengine.com/?lead_source=SportsEngine%20Platform&utm_source=footerlogo" onclick="javascript:window.location=('https://www.sportsengine.com/?lead_source=SportsEngine%20Platform&utm_source=footerlogo'); return false;"><img src="/logo_images/white_logo.png" alt="Powered by SportsEngine" title="Click here to learn how SportsEngine can empower your organization!" /></a></li>
    </ul>
</div>








<!-- Quantcast Tag, part 2 -->
<script type="text/javascript">
  _qevents.push({
    qacct: "p-56Ph9bjA0FOcE",
    labels: "Sport.football, State.MN, Site.1862, Ads.Yes"
  });
</script>
<noscript>
  <div style="display:none;">
    <img width="1" height="1" border="0" alt="Quantcast" src="https://pixel.quantserve.com/pixel/p-56Ph9bjA0FOcE.gif" />
  </div>
</noscript>
<!-- End Quantcast tag -->


<script src="https://storage.googleapis.com/didna-files/didna-pixel-se.js"></script>


  </footer>

  
    

<div id="PageSearch" class="theme-search-overlay" style="display:none;">
  <div class="theme-search-modal">
    <span class="theme-search-close"></span>
    <h1 class="theme-search-title">Team Finder</h1>
    <div class="theme-search-box">
      <input type="text" class="theme-search-input" />
      <span class="theme-search-clear"></span>
    </div>
    <div class="theme-search-results">
      <img class="theme-search-spinner" src="/app_images/loaderBarUserMode.gif" />
      <span class="theme-search-status"></span>
      <!-- search results here -->
    </div>
  </div>
</div>

<script type="text/javascript" charset="utf-8">
  new NGIN.PageSearchModal('#PageSearch', {
    inputElement: '.theme-search-input',
    statusElement: '.theme-search-status',
    spinnerElement: '.theme-search-spinner',
    clearElement: '.theme-search-clear',
    resultsElement: '.theme-search-results',
    closeElement: '.theme-search-close',
  });
</script>

  

  
    <div id="GoogleContentSearch" class="theme-search-overlay" style="display:none;">
  <div class="theme-search-modal">
    <span class="theme-search-close"></span>
    <h1 class="theme-search-title">Content Search</h1>
    <div class="theme-search-box">
      <gcse:searchbox gname="GoogleSearch"></gcse:searchbox>
    </div>
    <div class="theme-search-results">
      <gcse:searchresults gname="GoogleSearch"></gcse:searchresults>
    </div>
  </div>
</div>

<script type="text/javascript" charset="utf-8">
  new NGIN.GoogleSearchModal('#GoogleContentSearch', {
    closeElement: '.theme-search-close',
  });
</script>

<script>
  // Google Generated Code
  (function() {
    var cx = '011769658581138827714:9pvpnwiqiok';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>

  

</body>
</html>
